guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mike.jum...@guac-dev.org>
Subject Re: Compilation error on 0.9.12
Date Tue, 25 Apr 2017 19:33:27 GMT
> Thanks for hint. However, I see that error is present  quite a long time, since February

While the issue is definitely a bug, it's not a high priority relative
to other things being actively worked on, particularly since (1) it
involves compatibility between an optional component and an older
version of a dependency, and (2) there is a known workaround.

The build is absolutely fine on platforms having the newer version of
that dependency.

> Why not to replace libjpeg with the actual version where this function exists.

Well, that's not quite how it works.

The issue is not that the build uses libjpeg / libjpeg-turbo, but that
the version of the library installed in your case lacks the
jpeg_mem_src() function. That function is present in newer releases of
those libraries.

It would be possible to automatically disable the guacenc build if
jpeg_mem_src() is absent (the automatic equivalent to specifying
--disable-guacenc), but the real solution is to provide our own
jpeg_mem_src() for compatibility. Again, though, this isn't really a
high priority issue for the reasons cited above. It will, however, be
fixed eventually.

> If the build is not buildable it should be marked as nightly or some type of.

No, the source is definitely buildable, and the release is a release.
The issue here is not that the build fails on all platforms, but that
a specific component of the build fails on a specific platform. That
issue is a bug, and will be fixed when possible, but that doesn't mean
that everything must be considered a nightly until the codebase is bug
free.

Thanks,

- Mike


On Tue, Apr 25, 2017 at 11:02 AM, Suncatcher16 <suncatcher16@outlook.com> wrote:
> Thanks for hint. However, I see that error is present  quite a long time
> <http://apache-guacamole-incubating-users.2363388.n4.nabble.com/build-error-on-ubuntu-with-guacenc-jpeg-decoder-td360.html>
> , since February. Why not to replace libjpeg with the actual version where
> this function exists. It is not cool to release such raw builds which just
> don't compile. If the build is not buildable it should be marked as nightly
> or some type of.
>
>
>
> --
> View this message in context: http://apache-guacamole-incubating-users.2363388.n4.nabble.com/Compilation-error-on-0-9-12-tp835p840.html
> Sent from the Apache Guacamole (incubating) - Users mailing list archive at Nabble.com.

Mime
View raw message