guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mike.jum...@guac-dev.org>
Subject Re: Recommended FreeRDP Version with Support for "Display Update"
Date Wed, 05 Apr 2017 20:24:39 GMT
On Apr 5, 2017 12:58, "Rocky Borrego" <rocky@nextstepcloud.com> wrote:

Oh, now that makes a lot more sense.  Thank you.

After I build it on the server with 'make install' do I need to rebuild the
guacamole server?


Yes. You'll need to rerun ./configure, so that the build takes note of the
different version of FreeRDP, and then rerun make and make install.

I would also recommend doing a make clean first, to ensure that the past
build is cleaned up.

The API of each release of FreeRDP is drastically different, and a decent
majority of Guacamole's configure script is devoted to detecting the
different versions, enabling/disabling sections of Guacamole's RDP build as
a result. Things will not build correctly, if at all, if you do not rerun
configure.


Also, when I first setup the server (initially) I installed the Debian
package libfreerdp-dev.  Do i need to remove/purge that package after
building FreeRDP from the git source?



Yes. In fact, I would recommend removing both libfreerdp-dev and libfreerdp
prior to building FreeRDP from git.

- Mike

Mime
View raw message