guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Salatiel Filho <salatiel.fi...@gmail.com>
Subject Can't create connections. Error popup!
Date Wed, 12 Apr 2017 13:43:48 GMT
Hello, i have just installed guacamole using docker containers. The
web interface is working just fine, i can login   just fine, but when
i try to create a new connection i just get the popup  "ERROR" and no
other information. Nothing is written in the log.
Here is what i am doing:

1) Login
2) Settings
3) Connections
4) New Connection
Name = Name
Location = ROOT
Protocol = VNC
Hostname = MyHostname
Port = Myport
Password = MyPassword
5) Save Button
So i get the error. I have uploaded a screenshot here:
https://unsee.cc/gemazupo/

Tried with rdp and got the same error.

There is nothing on the logs after my login.

# docker logs -f guacamole
...
13:14:22.176 [http-nio-8080-exec-5] INFO
o.a.g.r.auth.AuthenticationService - User "root" successfully
authenticated from [192.168.254.1, 172.17.0.1].

# docker logs -f guacd
guacd[1]: INFO: Guacamole proxy daemon (guacd) version 0.9.12-incubating started
guacd[1]: INFO: Listening on host 0.0.0.0, port 4822


Here how i created my containers: (The initial database process was
done correctly)
#docker run --name guac-mysql  -e MYSQL_ROOT_PASSWORD='***' -d mysql:latest
# docker run --name guacd -d guacamole/guacd
# docker run --name guacamole --link guacd:guacd --link
guac-mysql:mysql -e MYSQL_DATABASE='***' -e MYSQL_USER='***'   -e
MYSQL_PASSWORD='***' -d -p 8080:8080 guacamole/guacamole

Any ideas ?







[]'s
Salatiel

Mime
View raw message