guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrews, Keith" <Keith_Andr...@alliedtelesis.com>
Subject SSH & Private Key
Date Sat, 01 Apr 2017 23:57:58 GMT
Hello,

I am wondering if anyone out there can help me figure out what is wrong with my noauth-config
configuration for SSH using a private key without a passphrase.  Here is the config in noauth-config.xml:

    <config name="AWS" protocol="ssh">
        <param name="hostname" value="192.168.1.100" />
        <param name="port" value="22" />
        <param name="username" value="ubuntu" />
        <param name="private-key" value="-----BEGIN RSA PRIVATE KEY----- Verylongprivatekey..................................................................................
-----END RSA PRIVATE KEY-----" />
    </config>

Upon connection I am prompted for a passphrase even though this key does not have one.  I
even tried putting the param name="passphrase" value="" and it still doesn't work.  Any help,
tips, etc is very much appreciated.

Thank you,
Keith

This e-mail message is for the sole use of the intended recipient(s) and may contain confidential
and privileged information. Any unauthorized review, use, disclosure or distribution is prohibited.
If you are not the intended recipient, please contact the sender by reply e-mail and destroy
all copies of the original message. If you are the intended recipient, please be advised that
the content of this message is subject to access, review and disclosure by the sender's e-mail
System Administrator.

Mime
View raw message