I have, however, it seems I tried initially with the free version of Duo which did not include the Auth API application - once I upgraded and generated a new token for the Auth API (previously I was using “UNIX Application”) it worked.

Case closed!

- Kris

On Mar 13, 2017, at 4:01 PM, Mike Jumper <mike.jumper@guac-dev.org> wrote:

On Mon, Mar 13, 2017 at 8:27 AM, Kris Germann <kgermann@portal.net.co> wrote:

I'm wondering how to accomplish this, I have the following in my guacamole.preferences:

#MySQL Info
mysql-hostname: localhost
mysql-port: 3306
mysql-database: guacamole_db
mysql-username: guacamole_user
mysql-password: xxxxxxxxxxxx

#Duo Security API Info
duo-api-hostname: api-hostname.duosecurity.com
duo-integration-key: xxxxxxxxxxxxxxxxxxxx
duo-secret-key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
duo-application-key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

However, when I log in I get the following in the logs:

14:54:09.658 [http-nio-8080-exec-2] INFO o.a.g.r.auth.AuthenticationService - User "kgermann" successfully authenticated from 50.100.78.133.

However, I am greeted with:

<Screen Shot 2017-03-12 at 2.42.38 PM.png>

Any help would be appreciated :)



Have you verified that the integration key, secret key, and API hostname are exactly as listed by Duo in the application's "Details" section?

- Mike