guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kok Hooi Chew <chewkokh...@gmail.com>
Subject Re: ReverseVNC issue
Date Fri, 03 Mar 2017 00:28:12 GMT
Hi All,
I'm using Guacamole v0.9.10 with NoAuth extension. I'm having issues when
using ReverseVNC where most of the time it's either getting connection
timeout or screen is shown but no mouse cursor or screen is shown but not
updated

Guacd log
Mar  3 00:21:11 FMUbuntu guacd[1398]: Creating new client for protocol "vnc"
Mar  3 00:21:11 FMUbuntu guacd[1398]: Connection ID is
"$996828ec-99ca-4141-b49f-60f7ebd0ea25"
Mar  3 00:21:11 FMUbuntu guacd[40842]: Cursor rendering: local
Mar  3 00:21:11 FMUbuntu guacd[40842]: User
"@3a384570-f795-4722-a232-27d4fbd45a94" joined connection
"$996828ec-99ca-4141-b49f-60f7ebd0ea25" (1 users now present)
Mar  3 00:21:11 FMUbuntu guacd[40842]: Listening for connections on port
7716
Mar  3 00:21:11 FMUbuntu guacd[40842]:  -listennofork: Listening on port
7716
Mar  3 00:21:11 FMUbuntu guacd[40842]:  -listennofork: Command line errors
are not reported until a connection comes in.
Mar  3 00:21:15 FMUbuntu systemd[40649]: Time has been changed

Catalina log
00:21:11.455 [http-nio-8080-exec-1] INFO  o.a.g.tunnel.TunnelRequestService
- User "d8af80b4-233c-4a9f-bca0-83b980718e94" connected to connection
"ReverseVNC7716".
00:22:11.451 [http-nio-8080-exec-8] INFO  o.a.g.tunnel.TunnelRequestService
- User "d8af80b4-233c-4a9f-bca0-83b980718e94" disconnected from connection
"ReverseVNC7716". Duration: 59996 milliseconds
00:22:27.466 [http-nio-8080-exec-10] INFO
 o.a.g.tunnel.TunnelRequestService - User
"d8af80b4-233c-4a9f-bca0-83b980718e94" connected to connection
"ReverseVNC7716".
Exception in thread "Thread-1698" java.lang.IllegalStateException: Message
will not be sent because the WebSocket session has been closed
at
org.apache.tomcat.websocket.WsRemoteEndpointImplBase.writeMessagePart(WsRemoteEndpointImplBase.java:384)
at
org.apache.tomcat.websocket.WsRemoteEndpointImplBase.startMessage(WsRemoteEndpointImplBase.java:340)
at
org.apache.tomcat.websocket.WsRemoteEndpointImplBase$TextMessageSendHandler.write(WsRemoteEndpointImplBase.java:755)
at
org.apache.tomcat.websocket.WsRemoteEndpointImplBase.sendPartialString(WsRemoteEndpointImplBase.java:252)
at
org.apache.tomcat.websocket.WsRemoteEndpointImplBase.sendString(WsRemoteEndpointImplBase.java:195)
at
org.apache.tomcat.websocket.WsRemoteEndpointBasic.sendText(WsRemoteEndpointBasic.java:37)
at
org.apache.guacamole.websocket.GuacamoleWebSocketTunnelEndpoint$2.run(GuacamoleWebSocketTunnelEndpoint.java:169)

Appreciate your help as I'm having the same issues even though we setup a
new deployment

Thanks

Regards
Chew

On Fri, Mar 3, 2017 at 8:25 AM, Kok Hooi Chew <chewkokhooi@gmail.com> wrote:

> Hi All,
>
>

Mime
View raw message