guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From christian.kl...@ufz.de
Subject Re: NoAuth extension not working / Configuration not readed?
Date Tue, 07 Mar 2017 12:59:28 GMT
I finally figured out the reason, why it did not read 
"guacamole.properties".

Even though I did set the environment variable 
"GUACAMOLE_HOME=/etc/guacamole" by editing /etc/environment und 
reloading it with "source /etc/environment", that was probably the issue.

So instead of this path, I picked the tomcat home for storing all 
related Guacamole confs (located under /usr/share/tomcat7/.guacamole).

That fixed the issue and the config was loaded. It all works like a 
charm from now!

Anyways, this might be helpful for someone experiencing the same issues 
as me.

Best regards

Christian

BTW: How do you put the environment variable, so Guacamole is realizing 
it is actually set?


Am 01.03.2017 um 13:30 schrieb christian.klotz@ufz.de:
> One addition to this thread (besides the bad language I used in the 
> first post, sorry for that)
>
> The Host is a Ubuntu 14.04.05 LTS Virtual Machine running on a VMware 
> ESX Host.
>
> Best regards
>
> Christian
>
>
> Am 28.02.2017 um 13:54 schrieb christian.klotz@ufz.de:
>> Hello Guacamole Team,
>>
>> I am trying to get the NoAuth extension to work (version 0.9.11).
>>
>> I previously used Guacamole one year ago (that was version 0.9.7).
>>
>> Now I did a complete reinstallation of the newest Guacamole following 
>> the manual:
>>
>> So I downloaded the Guacamole Server, .war file and the NoAuth Plugin 
>> and compiled the server and deployed the client.
>>
>> As the next step I set up an environment variable under 
>> /etc/environment, which is named GUACAMOLE_HOME and points on the 
>> previously created directory /etc/guacamole. Then I created the 
>> "guacamole.properties" file with the following content (for use with 
>> NoAuth):
>>
>> guacd-host: localhost
>> guacd-port: 4822
>> noauth-config: /etc/guacamole/noauth-config.xml
>>
>> Next step was to create the "noauth-config.xml":
>>
>> <configs>
>>     <config name="desk5" protocol="rdp">
>>         <param name="hostname" value="test.intranet.ufz.de" />
>>     <param name="port" value="3389" />
>>     <param name="color-depth" value="16" />
>>     <param name="disable-audio" value="true" />
>>      <param name="security" value= "tls" />
>>      <param name="ignore-cert" value="true" />
>>     </config>
>> </configs>
>>
>> After that I created the extensions folder inside /etc/guacamole and 
>> placed the noauth.jar in it.
>>
>> As the last step I restarted both services guacd and tomcat7 and it 
>> did not send any error messages in the log.
>> So I checked it out in the browser, but unfortunately there is a 
>> login screen coming up.
>>
>> It seems like my configuration (guacamole.properties) is not loaded 
>> at all?
>>
>> Best Regards & looking forward for an answer
>>
>> Christian
>>
>


Mime
View raw message