guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mattias Besemann <mattias.besem...@gmail.com>
Subject Re: [Question] Guacamole not using WebSocket properly
Date Mon, 30 Jan 2017 19:51:40 GMT
Hi,

I'm running nginx 1.10.1 and Tomcat8.

Mattias

> Mike Jumper <mailto:mike.jumper@guac-dev.org>
> January-30-17 2:48 PM
> What version of Nginx are you using? Support for WebSocket was added 
> in Nginx 1.3, and older versions will not be able to proxy WebSocket 
> properly.
>
> - Mike
>
>
>
> Mattias Besemann <mailto:mattias.besemann@gmail.com>
> January-30-17 2:20 PM
> Hello,
>
> I am trying to configure guacamole to serve through nginx using a 
> WebSocket, and while I can access the application from the nginx 
> endpoint, I still receive the following error in the tomcat logs when 
> starting a session:
>
> 19:11:49.460 [http-nio-8080-exec-1] INFO  
> o.g.g.n.b.BasicGuacamoleTunnelServlet - Using HTTP tunnel (not 
> WebSocket). Performance may be sub-optimal.
>
> My nginx location configuration is as follows:
>
> location /guacamole/ {
>                 proxy_pass http://localhost:8080/guacamole/;
>                 proxy_buffering off;
>                 proxy_http_version 1.1;
>                 proxy_set_header X-Forwarded-For 
> $proxy_add_x_forwarded_for;
>                 proxy_set_header Upgrade $http_upgrade;
>                 proxy_set_header Connection $http_connection;
>                 access_log off;
>         }
>
> Is there anything else that needs to be done in order to get WebSocket 
> working?
>
> Cheers,
>
> Mattias

-- 
Sent from Postbox 
<https://www.postbox-inc.com/?utm_source=email&utm_medium=siglink&utm_campaign=reach>

Mime
View raw message