guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mike.jum...@guac-dev.org>
Subject Re: Required dependencies v0.9.9
Date Sat, 10 Dec 2016 04:12:25 GMT
On Fri, Dec 9, 2016 at 4:46 PM, Cyle <cyle@cogmation.com> wrote:
> Noticed in the Required dependencies section at
> https://guacamole.incubator.apache.org/doc/gug/installing-guacamole.html it
> mentions that libraries such as libjpeg-turbo and libpng are required to
> build guacamole-server. However, the build still succeeds even when these
> libraries are not present. Is this no longer a requirement?
>

They are very required. The configure script will fail outright if
either of those libraries are absent.

libjpeg (or libjpeg-turbo) is a relatively new requirement, added as
of 0.9.9, but libpng has been a requirement since around 0.3.0.

> I'm trying to optimize my guacamole-server with the libjpeg62-turbo-dev
> package, but I don't see any reference to it at all in the build process and
> I'm trying to verify that it's being incorporated.
>

The libraries present will be summarized by the configure script if
the minimum build requirements are met. If you have libjpeg (or
libjpeg-turbo), you will see libjpeg listed as present in the summary.

- Mike

Mime
View raw message