guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Caruso <fcaruso5...@gmail.com>
Subject Re: guacd segfault in libpthread
Date Sat, 12 Nov 2016 22:37:43 GMT
Thanks for the response Mike.

I reinstalled paring down the number of packages I was installing to
just what was on the site and that seems to have fixed the issue.
(I'll go through them one by one later and see which caused the issue)
 I do still see some odd behavior with sound.  The first sound to play
on the desktop opens a channel (for example a bing or chime)

guac guacd[10657]: Accepted format: 16-bit PCM with 2 channels at 44100 Hz

The next sound and subsuquent sounds seems to open a new channel that
doesn't play on my linux desktop (don't have a windows desktop handy
so haven't tried)

Nov 12 17:20:07 guac guacd[10657]: Capabilities sent.
Nov 12 17:20:07 guac guacd[10657]: Client ID confirmed
Nov 12 17:20:07 guac guacd[10657]: User logged on
Nov 12 17:20:07 guac guacd[10657]: All supported devices sent.
Nov 12 17:20:37 guac guacd[10657]: Accepted format: 16-bit PCM with 2
channels at 44100 Hz
Nov 12 17:27:08 guac guacd[10657]: Accepted format: 16-bit PCM with 2
channels at 44100 Hz
Nov 12 17:27:09 guac guacd[10657]: Accepted format: 16-bit PCM with 2
channels at 44100 Hz
Nov 12 17:27:12 guac guacd[10657]: Accepted format: 16-bit PCM with 2
channels at 44100 Hz
Nov 12 17:27:18 guac guacd[10657]: Accepted format: 16-bit PCM with 2
channels at 44100 Hz
Nov 12 17:27:20 guac guacd[10657]: Accepted format: 16-bit PCM with 2
channels at 44100 Hz

If that firest sound was a video it plays normally and I can pause,
jump around, etc.  I can also play other sounds while the video is
playing but as soon as the video closes I loose all sound again.
Could this be a guacd issue or more likely a pulse audio issue?

thanks



On Fri, Nov 11, 2016 at 5:13 PM, Mike Jumper <mike.jumper@guac-dev.org> wrote:
> Could there be files hanging around from a previous install of Guacamole
> (such as guacsnd.so or guacsnd-client.so)?
>
> - Mike
>
>
> On Thu, Nov 10, 2016 at 10:29 AM, Frank Caruso <fcaruso5648@gmail.com>
> wrote:
>>
>> Quick update.  The issue seems to be something with audio.  Whenever a
>> sound would be made on the windows side it's transfered over and kills
>> guacd with a segfault.
>>
>> Thanks
>> Frank
>>
>> On Wed, Nov 9, 2016 at 2:33 PM, Frank Caruso <fcaruso5648@gmail.com>
>> wrote:
>> > Hello,
>> >
>> > I'm hitting an error using guacamole 9.9 with windows 10.  I've done a
>> > clean install from source on Centos 7 minimal and I can connect to my
>> > Windows 10 nuc.  While using the connection through firefox and chrome
>> > the connection will freeze usually when a notification appears.
>> > Looking at the log I see the following error.
>> >
>> > kernel: guacd[2655]: segfault at 4800f9 ip 00007f8e5ea7cbd0 sp
>> > 00007f8e544dfbf8 error 4 in libpthread-2.17.so[7f8e5ea73000+16000].
>> >
>> > Not really an error I know where to start with.
>> >
>> > Any help would be greatly appreciated
>> >
>> > Thanks
>> >
>> > Franko
>
>

Mime
View raw message