guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mike.jum...@guac-dev.org>
Subject Re: Guacamole/App limitations
Date Tue, 04 Oct 2016 17:42:28 GMT
On Oct 4, 2016 10:32, "Antony Awaida" <antony@apporto.com> wrote:
>
> ...
>
> Are the gaps in HTML5 support not relevant to Guac and desktop
applications?
>

Yes.

At it's core, Guacamole requires only support for the canvas tag and either
advanced XHR (for the HTTP tunnel) or WebSocket (for the WebSocket tunnel):

http://caniuse.com/#feat=canvas

+

http://caniuse.com/#feat=xhr2 OR http://caniuse.com/#feat=websockets

If you want audio, you also need the Web Audio API:

http://caniuse.com/#feat=audio-api

The UI we provide within the Guacamole web application additionally depends
on CSS support for "display: flex", though this is not necessarily relevant
if you are integrating guac functionality into your own app using the APIs:

http://caniuse.com/#feat=flexbox

- Mike

Mime
View raw message