guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cahill, Benjamin" <bcah...@alertacademy.com>
Subject guacamole 0.9.9 immediately disconnects all sessions
Date Fri, 12 Aug 2016 16:59:13 GMT
Hello!

This is my first time on the mailing list, and my first time using
guacamole! I have heard many things about its awesome-ness and want to
join in on the fun.

This is also the first mailing list I have used, so I would appreciate
any advice or tips to help me help you help me. (haha!) I have set my
Gmail editor to plain text mode and will be sure and reply on the
bottom, as I have heard is appreciated. :-)

Alrighty, my problem is that I cannot get guacamole 0.9.9 to connect
using RDP or SSH. I have set up several profiles testing Windows 10
(RDP), Windows XP (RDP), and Linux (SSH) boxes to no avail.

I always get this error in my browser when attempting a connection:

"An internal error has occurred within the Guacamole server, and the
connection has been terminated. If the problem persists, please notify
your system administrator, or check your system logs."

After dutifully checking my system logs, I am still dumbfounded!

/var/log/syslog:

Aug 12 11:50:09 guac-test guacd[20075]: Protocol "rdp" selected
Aug 12 11:50:09 guac-test guacd[20075]: Connection ID is
"$28dacd08-07c5-4cc1-bbad-e09d4acbfd44"
Aug 12 11:50:09 guac-test guacd[20075]: No security mode specified.
Defaulting to RDP.
Aug 12 11:50:09 guac-test guacd[20075]: Loading keymap "base"
Aug 12 11:50:09 guac-test guacd[20075]: Loading keymap "en-us-qwerty"
Aug 12 11:50:10 guac-test guacd[20075]: Starting client
Aug 12 11:50:10 guac-test guacd[20075]: Client disconnected

/var/log/tomcat8/catalina.out:

11:50:10.227 [http-nio-8080-exec-7] INFO
o.g.g.net.basic.TunnelRequestService - User "guacadmin" connected to
connection "1".
Aug 12, 2016 11:50:10 AM
org.apache.coyote.AbstractProtocol$AbstractConnectionHandler process
FINE: Socket: [org.apache.tomcat.util.net.NioEndpoint$KeyAttachment@21901082:org.apache.tomcat.util.net.NioChannel@5ff7f554:java.nio.channels.SocketChannel[connected
local=/192.168.0.24:8080 remote=/192.168.0.253:60684]], Status in:
[OPEN_READ], State out: [UPGRADING]
Aug 12, 2016 11:50:10 AM
org.apache.coyote.AbstractProtocol$AbstractConnectionHandler process
FINE: Socket: [org.apache.tomcat.util.net.NioEndpoint$KeyAttachment@21901082:org.apache.tomcat.util.net.NioChannel@5ff7f554:java.nio.channels.SocketChannel[connected
local=/192.168.0.24:8080 remote=/192.168.0.253:60684]], Status in:
[OPEN_READ], State out: [UPGRADED]
Aug 12, 2016 11:50:10 AM
org.apache.tomcat.websocket.server.WsFrameServer onDataAvailable
FINE: wsFrameServer.onDataAvailable
11:50:10.233 [http-nio-8080-exec-8] INFO
o.g.g.net.basic.TunnelRequestService - User "guacadmin" disconnected
from connection "1". Duration: 6 milliseconds

This is with ".level = FINE" in /etc/tomcat8/logging.properties. There
are many more logs from tomcat8 but I didn't want to post to many. I
am new to both guacamole and tomcat but not to Linux. Let me know if I
should look for something specific or provide other logs.

Ubuntu 16.04.
Tried guacamole-0.8.3 from the Ubuntu repos and it worked but I wanted
to use the latest version.
Used a PPA here:
https://launchpad.net/~dnjl/+archive/ubuntu/network-build/+packages
That had the same problem I described above so then I built from
source with the script here:
http://chasewright.com/guacamole-with-mysql-on-ubuntu/
I am using a VM and have returned to the base snapshot (just a base
install of Ubuntu 16.04 + set IP) between each try, so there is
nothing residual between them. All I have described above is what I
see on the 0.9.9 build from source.

Any ideas would be greatly appreciated!

Thanks,
 - Benjamin Cahill

Mime
View raw message