guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neil Canham <neil.can...@vcommsolutions.com>
Subject Pointers for debugging latest build
Date Thu, 07 Jul 2016 16:04:13 GMT
Hi
  Having successfully installed and tested Guacamole 0.9.9 against a couple
of RDP connections, I've now tried to build the client and server (I want
to try out the desktop sharing functionality in the API).  Build has gone
fine, then I had an issue with the FreeRDP libraries not being found (as
reported by running guacd directly in the console);

freerdp_load_library_symbol: failed to open
/usr/lib/x86_64-linux-gnu/freerdp/guacsnd.so:
/usr/lib/x86_64-linux-gnu/freerdp/guacsnd.so: cannot open shared object
file: No such file or directory

Solved by creating symbolic link as in this thread:
https://sourceforge.net/p/guacamole/discussion/1110834/thread/35f991bb/

ie:  ln -s /usr/local/lib/freerdp/guac* /usr/lib/x86_64-linux-gnu/freerdp/

After that, the webapp looked as if it was connecting.  Log shows:

guacd[684]: INFO:       Creating new client for protocol "rdp"
guacd[684]: INFO:       Connection ID is
"$f45458f8-df00-42df-a751-c85623e9f159"
guacd[699]: DEBUG:      Parameter "console" omitted. Using default value of
0.
guacd[699]: DEBUG:      Parameter "console-audio" omitted. Using default
value of 0.
guacd[699]: DEBUG:      Parameter "ignore-cert" omitted. Using default
value of 0.
guacd[699]: DEBUG:      Parameter "disable-auth" omitted. Using default
value of 0.
guacd[699]: INFO:       No security mode specified. Defaulting to RDP.
guacd[699]: DEBUG:      User resolution is 1562x920 at 96 DPI
guacd[699]: DEBUG:      Parameter "dpi" omitted. Using default value of 96.
guacd[699]: DEBUG:      Using resolution of 1560x920 at 96 DPI
guacd[699]: DEBUG:      Parameter "enable-wallpaper" omitted. Using default
value of 0.
guacd[699]: DEBUG:      Parameter "enable-theming" omitted. Using default
value of 0.
guacd[699]: DEBUG:      Parameter "enable-font-smoothing" omitted. Using
default value of 0.
guacd[699]: DEBUG:      Parameter "enable-full-window-drag" omitted. Using
default value of 0.
guacd[699]: DEBUG:      Parameter "enable-desktop-composition" omitted.
Using default value of 0.
guacd[699]: DEBUG:      Parameter "enable-menu-animations" omitted. Using
default value of 0.
guacd[699]: DEBUG:      Parameter "color-depth" omitted. Using default
value of 16.
guacd[699]: DEBUG:      Parameter "disable-audio" omitted. Using default
value of 0.
guacd[699]: DEBUG:      Parameter "enable-printing" omitted. Using default
value of 0.
guacd[699]: DEBUG:      Parameter "enable-drive" omitted. Using default
value of 0.
guacd[699]: DEBUG:      Parameter "drive-path" omitted. Using default value
of "".
guacd[699]: DEBUG:      Parameter "create-drive-path" omitted. Using
default value of 0.
guacd[699]: DEBUG:      Parameter "recording-name" omitted. Using default
value of "recording".
guacd[699]: DEBUG:      Parameter "create-recording-path" omitted. Using
default value of 0.
guacd[699]: INFO:       Resize method: none
guacd[699]: INFO:       User "@9795d9ab-d36e-44bd-b189-4252baec05b0" joined
connection "$f45458f8-df00-42df-a751-c85623e9f159" (1 users now present)
guacd[699]: INFO:       Loading keymap "base"
guacd[699]: INFO:       Loading keymap "en-us-qwerty"
connected to <IP-removed>:3389
guacd[699]: INFO:       guacdr connected.
guacd[699]: INFO:       guacsnd connected.
guacd[684]: INFO:       Connection "$f45458f8-df00-42df-a751-c85623e9f159"
removed.

So the connection is formed, then removed.  No reason given.  Webapp never
showed the desktop but RDP connection was definitely made (I know that
because I kept a Windows RDP session connected one time and it was forcibly
closed when Guacamole connected)

So two things:

1. Is the symbolic link above required? Is it the right solution?
2. Any way I can find out more on why this isn't connecting?

Mime
View raw message