guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mahmoud El Tabarane" <tabar...@gmail.com>
Subject RE: VNC with Guacamole Error { SEVERE: Server error in tunnel }
Date Sat, 23 Jul 2016 20:02:29 GMT
Here is the guacd Log also 

 

Protocol "vnc" selected

VNC server supports protocol version 3.889 (viewer 3.8)

We have 3 security types to read

0) Received security type 30

1) Received security type 2

Selecting security type 2 (1/3 in the list)

2) Received security type 35

Selected Security Scheme 2

VNC authentication succeeded

Desktop name "OSX's Mac ENG"

Connected to VNC server, using protocol version 3.8

VNC server default format:

32 bits per pixel.

Least significant byte first in each pixel.

TRUE colour: max red 255 green 255 blue 255, shift red 16 green 8 blue 0

Starting client

Error reading instruction: End of stream reached while reading instruction:
End of input stream

Client finished normally

 


Mahmoud El Tabarane   

Senior IT System Admin, 


Mobile: +7 (925) 208-32-13 

Email:  <mailto:Tabarane@gmail.com> Tabarane@gmail.com 

Website:  <http://www.mycertprofile.com/Profile/8157259648>
http://www.mycertprofile.com/Profile/8157259648 

 <https://ru.linkedin.com/in/meltabarane> 

 

 

From: Mahmoud El Tabarane [mailto:tabarane@gmail.com] 
Sent: Friday, July 22, 2016 9:29 PM
To: user@guacamole.incubator.apache.org
Subject: RE: VNC with Guacamole Error { SEVERE: Server error in tunnel }

 

Example how the site looks like and what link is generated when user click
the Connect Button

 



 

This is the generated link by Apache when user Click on Connect Button

 



 

 


Mahmoud El Tabarane   

Senior IT System Admin, 


Mobile: +7 (925) 208-32-13 

Email:  <mailto:Tabarane@gmail.com> Tabarane@gmail.com 

Website:  <http://www.mycertprofile.com/Profile/8157259648>
http://www.mycertprofile.com/Profile/8157259648 

 <https://ru.linkedin.com/in/meltabarane> 

 

 

From: Mahmoud El Tabarane [mailto:tabarane@gmail.com] 
Sent: Friday, July 22, 2016 9:18 PM
To: user@guacamole.incubator.apache.org
<mailto:user@guacamole.incubator.apache.org> 
Subject: VNC with Guacamole Error { SEVERE: Server error in tunnel }

 

Hello , 

 

I have Guacamole Server 0.6.2 installed on Debian 6 Squeeze

website is based on Apache 2.2 and Tomcat6 for Guac

 

Basically I have a button in front of the VM at my frontend website ,so when
user want to connect he press connect button and the VM load the RDP
connection inside the browser 

apache do the redirecting part ( proxy / reverse proxy ) 

 

</VirtualHost>

<VirtualHost *:1080>

               ProxyRequests off

               Proxyvia on

# Pass for Guac

        Proxypass /user2/rdp http://127.0.0.1:8080/user2

        ProxyPassReverse /user2/rdp http://127.0.0.1:8080/user2

        Proxypass /user3/rdp http://127.0.0.1:8080/user3

        ProxyPassReverse /user3/rdp http://127.0.0.1:8080/user3

 

,So every user get redirect to the machine he need
machines IP/port /pass/protocol is based on ( etc/guacamole/user-mapping )

 

 

All RDP connection is working , VNC connection give me this error on
catalina.out

 

Jul 22, 2016 3:21:53 PM org.slf4j.impl.JCLLoggerAdapter info

INFO: Successful connection from 127.0.0.1 to "OSX ElCapitano ENG".

Jul 22, 2016 3:21:53 PM org.slf4j.impl.JCLLoggerAdapter info

INFO: Connection from 127.0.0.1 succeeded.

Jul 22, 2016 3:21:55 PM org.slf4j.impl.JCLLoggerAdapter error

SEVERE: Server error in tunnel

net.sourceforge.guacamole.GuacamoleServerException: Element terminator of
instruction was not ';' nor ','

                at
net.sourceforge.guacamole.io.ReaderGuacamoleReader.read(ReaderGuacamoleReade
r.java:147)

                at
net.sourceforge.guacamole.servlet.GuacamoleHTTPTunnelServlet.doRead(Guacamol
eHTTPTunnelServlet.java:302)

                at
net.sourceforge.guacamole.servlet.GuacamoleHTTPTunnelServlet.handleTunnelReq
uest(GuacamoleHTTPTunnelServlet.java:182)

                at
net.sourceforge.guacamole.servlet.GuacamoleHTTPTunnelServlet.doGet(Guacamole
HTTPTunnelServlet.java:89)

                at
javax.servlet.http.HttpServlet.service(HttpServlet.java:617)

                at
javax.servlet.http.HttpServlet.service(HttpServlet.java:723)

                at
net.sourceforge.guacamole.net.basic.BasicGuacamoleTunnelServlet.authenticate
dService(BasicGuacamoleTunnelServlet.java:63)

                at
net.sourceforge.guacamole.net.basic.AuthenticatingHttpServlet.service(Authen
ticatingHttpServlet.java:265)

                at
javax.servlet.http.HttpServlet.service(HttpServlet.java:723)

                at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Application
FilterChain.java:290)

                at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterCh
ain.java:206)

                at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.ja
va:233)

                at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.ja
va:191)

                at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127
)

                at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103
)

                at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
:109)

                at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)

                at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:861)

                at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http
11Protocol.java:606)

                at
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)

                at java.lang.Thread.run(Thread.java:679)

 

 

 

I checked if libvncserver-dev server is installed and 

 

~# apt-get install libvncserver-dev

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

 

The following packages have unmet dependencies:

libvncserver-dev : Depends: libvncserver0 (= 0.9.7-2+deb6u1) but
0.9.9+dfsg-1 is to be installed

 

I tried to install the libvncserver0 but it's not happing 

 

 

~#apt-get install libvncserver0

Reading package lists... Done

Building dependency tree

Reading state information... Done

libvncserver0 is already the newest version.

The following packages were automatically installed and are no longer
required:

  libmysqlclient18 libperl5.14 mysql-common

Use 'apt-get autoremove' to remove them.

0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

 

any idea what is going wrong? I need to have the connection working on VNC
machines ex.OSX

 

 

 

	

Mahmoud El Tabarane   

Senior IT System Admin, 


Mobile: +7 (925) 208-32-13 

Email:  <mailto:Tabarane@gmail.com> Tabarane@gmail.com 

Website:  <http://www.mycertprofile.com/Profile/8157259648>
http://www.mycertprofile.com/Profile/8157259648 

 <https://ru.linkedin.com/in/meltabarane> 

 

 


Mime
View raw message