guacamole-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Kopp <AK...@soleilfoodservice.com>
Subject RE: Guacamole - Session Disconnects
Date Tue, 07 Jun 2016 02:28:51 GMT
Hi Brian,

I experience the same session disconnects you are describing however we do not use no-auth
and use various hosts (Windows 7, Windows Server 2008 R2 and 2012 R2). We do have RDP policies
configured to keep the disconnected sessions running like in your scenario, however in your
case, check the policy that kicks and disconnects idle sessions (this will keep the session
still running in the background - https://technet.microsoft.com/en-us/library/cc754272(v=ws.11).aspx).
Even though we have ensured this policy was configured properly on our servers the sessions
still randomly drop (but much less!). We have particularly noted this behavior on slow or
unreliable internet connections (like cellphone tethering) and saturated connections (shared
wifi at a coffee shop).

The only thing we do that is different than out of the box is utilize mod_proxy and perform
SSL on the web browser connection. This is the path: web browser (SSL) -> apache(reverse
proxy – non ssl) -> guac daemon (same box) -> RDP hosts both on same segment and remote
segments.

From what I can tell after doing tcpdumps, the disconnects are due to chrome and how it handles
the connection between the guac daemon and the client browser. We have not been able to produce
reliable patterns however we are continuing to monitor the service and network.


Regards,

Andrew


From: Brian Henry [mailto:behenry@itveterans.com]
Sent: Monday, June 6, 2016 8:35 PM
To: user@guacamole.incubator.apache.org
Subject: Guacamole - Session Disconnects

To anyone that has experienced the following session disconnects from the web browser to RDP
session.  Once reconnected to the RDP desktop all of the applications are still running.

The configuration is setup in a No-Auth configuration which puts the user right at the Windows
2012 R2 login.  Once logged into the RDP session, the guac session to the RDP server periodically
disconnects at random times with no distinct pattern.  The current version of guac running
is 0.9.9 on the system.  I can get the exact version of web browsers being used but are Explorer
and Mozilla.

v/r,

Brian



________________________________

This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed. If you have received this email
in error please disregard. This message may contain confidential information and is intended
only for the individual named.

Mime
View raw message