guacamole-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fermi Jiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GUACAMOLE-125) Sometimes session is not initialised on Full screen
Date Fri, 18 Aug 2017 00:59:00 GMT

    [ https://issues.apache.org/jira/browse/GUACAMOLE-125?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16131555#comment-16131555
] 

Fermi Jiang commented on GUACAMOLE-125:
---------------------------------------

Nick, thank you very much. After compiling FreeRDP 1.1 and re-compiling our Guacamole Server
source codes, the issue is solved. I would like to provide some more info after further investigation.
Hope it could help to narrow down where the root cause is.

1. This issue happens to us on CentOS 6 occasionally (say once several months) as well. But
after we log out and log in the remote app again, the issue is gone. However, this issue happens
every time with CentOS 7, and cannot be solved by log out / log in. You mentioned "CentOS
7 ships with FreeRDP 1.0.2" is a good point to me. I am not sure which version of FreeRDP
is shipped with CentOS 6. But this could be a clue regarding the difference between the two
versions of FreeRDP.

2. We are not using the binary package freerdp on CentOS directly. Instead, we are using the
package freerdp-devel and freerdp-plugins (via yum install). Then we compiles the source codes
of guacamole-server. I have recompiled FreeRDP 1.1 from git, and then removed the existing
package freerdp-devel and freerdp-plugins 1.0.2 (via yum remove). If I understand correctly,
when I recompile the source codes of guacamole-server, a part of the header files and source
codes from FreeRDP 1.1 are included. So the difference should be in that part.

3, After recompiling guacamole-server, below files are updated in /usr/local/lib/freerdp.
guacdr-client.la
guacdr-client.so
guacsnd-client.la
guacsnd-client.so
guacsvc-client.la
guacsvc-client.so
But below files are not updated, so they should be irrelevant.
guacdr.la
guacdr.so
guacsnd.la
guacsnd.so
guacsvc.la
guacsvc.so


> Sometimes session is not initialised on Full screen 
> ----------------------------------------------------
>
>                 Key: GUACAMOLE-125
>                 URL: https://issues.apache.org/jira/browse/GUACAMOLE-125
>             Project: Guacamole
>          Issue Type: Bug
>    Affects Versions: 0.9.9, 0.9.10-incubating
>         Environment: Guacamole running on Debian 8.6
> Forwarding a windows 2012 R2 session
>            Reporter: Frank Giroud
>            Priority: Critical
>         Attachments: fj1.png, fj2.png, fj3.png, fj4.png, fj5.png, fj6.png, notepad_size_limit_detail.jpg,
notepad_size_limit.jpg
>
>
> Sometimes after logging in (which happens to be Full scren) the windows session or the
RemoteApp is not launched in full screen.
> In fact it behaves like there were a pseudo-resolution smaller than the required one.
> The browser (Chrome is open in a 1920*1200) but the screen displayed is locked to something
like 1024*768 or so. 
> When you click on the Fullscreen button. It open and let a black screen all around in
the web browser. .
> -The behavior is the same if you start a windows session , the windows desktop displayed
in the web browser is in a 'smaller display' and what remains is black.- Haven't succeed to
reproduce after all
> I have succeeded to find a way to reproduce the behavior "kind of" more often.
> In my example i configure notepad++ to be a remoteapp (launch by ||notepad in guacamole
)
> # Launch a session through Guacamole => No probleme guacamole can be set in fullscreen
(on all the browser window)
> # Unmaximized the application
> # Ctrl-Shift-Alt menu => Disconnect
> # On the guacamole option menu (3 choices) => Reconnect
> # The result => my screenshot



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message