guacamole-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vn...@apache.org
Subject [3/6] incubator-guacamole-manual git commit: GUACAMOLE-314: Document that PostgreSQL permissions need to be re-granted after upgrading.
Date Sun, 04 Jun 2017 02:48:42 GMT
GUACAMOLE-314: Document that PostgreSQL permissions need to be re-granted after upgrading.


Project: http://git-wip-us.apache.org/repos/asf/incubator-guacamole-manual/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-guacamole-manual/commit/277586d1
Tree: http://git-wip-us.apache.org/repos/asf/incubator-guacamole-manual/tree/277586d1
Diff: http://git-wip-us.apache.org/repos/asf/incubator-guacamole-manual/diff/277586d1

Branch: refs/heads/master
Commit: 277586d10addadea9fe6034dcbfa986398930b60
Parents: c659c81
Author: Michael Jumper <mjumper@apache.org>
Authored: Thu Jun 1 23:57:39 2017 -0700
Committer: Michael Jumper <mjumper@apache.org>
Committed: Fri Jun 2 22:56:08 2017 -0700

----------------------------------------------------------------------
 src/chapters/jdbc-auth.xml | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-guacamole-manual/blob/277586d1/src/chapters/jdbc-auth.xml
----------------------------------------------------------------------
diff --git a/src/chapters/jdbc-auth.xml b/src/chapters/jdbc-auth.xml
index 64ac2dc..710a2ff 100644
--- a/src/chapters/jdbc-auth.xml
+++ b/src/chapters/jdbc-auth.xml
@@ -275,6 +275,22 @@ ALTER TABLE
 ALTER TABLE</computeroutput>
 <prompt>$</prompt></screen>
                 </informalexample>
+                <para>Because the permissions granted to the Guacamole-specific PostgreSQL
user when
+                    the database was first created will not automatically be granted for
any new
+                    tables and sequences, you will also need to re-grant those permissions
after
+                    applying any upgrade relevant scripts:</para>
+                <informalexample>
+                    <screen><prompt>$</prompt> <userinput>psql -d
<replaceable>guacamole_db</replaceable></userinput>
+<computeroutput>psql (9.3.6)
+Type "help" for help.
+</computeroutput>
+<prompt>guacamole=# </prompt><userinput>GRANT SELECT,INSERT,UPDATE,DELETE
ON ALL TABLES IN SCHEMA public TO <replaceable>guacamole_user</replaceable>;</userinput>
+<computeroutput>GRANT</computeroutput>
+<prompt>guacamole=# </prompt><userinput>GRANT SELECT,USAGE ON ALL SEQUENCES
IN SCHEMA public TO <replaceable>guacamole_user</replaceable>;</userinput>
+<computeroutput>GRANT</computeroutput>
+<prompt>guacamole=# </prompt><userinput>\q</userinput>
+<prompt>$</prompt></screen>
+                </informalexample>
                 <para>If there are no
                         <filename>upgrade-pre-<replaceable>VERSION</replaceable>.sql</filename>
                     scripts present in the <filename>schema/upgrade/</filename>
directory which


Mime
View raw message