guacamole-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Goldey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GUACAMOLE-205) libguac_common_ssh build fails with OpenSSL 1.1
Date Thu, 29 Jun 2017 01:03:00 GMT

    [ https://issues.apache.org/jira/browse/GUACAMOLE-205?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16067537#comment-16067537
] 

Mark Goldey commented on GUACAMOLE-205:
---------------------------------------

Thanks, Michael.  I do see that now.  I was able to compile 0.9.13 from git and can confirm
that the errors have vanished.

Ironically, I'm back to where I started those many months ago, when I upgraded my Debian box
from Jessie to Stretch and 0.9.9 stopped authenticating despite having worked fine before
and no change in user-mapping.xml or any other configuration files.  I get this in catalina.out:

{code:none}20:55:12.899 [https-jsse-nio-8443-exec-3] WARN  o.a.g.r.auth.AuthenticationService
- Authentication attempt from xx.xxx.xx.xxx for user "mark" failed.{code}

I tried using the 0.9.12 guacamole.war and it does the same thing.  Is there a specific .war
file to instead use with 0.9.13?  I couldn't find one.

Again, thanks for all your help.

> libguac_common_ssh build fails with OpenSSL 1.1
> -----------------------------------------------
>
>                 Key: GUACAMOLE-205
>                 URL: https://issues.apache.org/jira/browse/GUACAMOLE-205
>             Project: Guacamole
>          Issue Type: Bug
>          Components: guacamole-server, SSH
>    Affects Versions: 0.9.11-incubating
>         Environment: Linux 4.9.0-1-686-pae #1 SMP Debian 4.9.2-2 (2017-01-12) i686 GNU/Linux
>            Reporter: Mark Goldey
>            Assignee: Michael Jumper
>             Fix For: 0.9.13-incubating
>
>
> There are a number of changes in OpenSSL 1.1 which break compatibility with older versions
of the API, and which break the Guacamole build if OpenSSL 1.1 is present, particularly the
removal of threading callbacks (replaced with no-op macros) and the migration to opaque structures
with public accessor functions. The error below is due to the no-op macros, and fixing those
reveals further errors due to the new and required public accessor functions.
> A rough list is here:
> https://wiki.openssl.org/index.php/1.1_API_Changes
> The Guacamole build will need to be updated to take these changes into account. The original
issue report:
> {quote}
> I have compiled and used guacamole since v. 9.8 or so.  I just downloaded the source
for 9.11-incubating.  ./configure works fine.  Make terminates with the following error:
> {code:none}
> make[2]: Entering directory '/home/xxx/guacamole-server-0.9.11-incubating/src/common-ssh'
>   CC       libguac_common_ssh_la-guac_sftp.lo
>   CC       libguac_common_ssh_la-guac_ssh.lo
> guac_ssh.c:89:22: error: ‘guac_common_ssh_openssl_id_callback’ defined but not used
[-Werror=unused-function]
>  static unsigned long guac_common_ssh_openssl_id_callback() {
>                       ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> guac_ssh.c:70:13: error: ‘guac_common_ssh_openssl_locking_callback’ defined but not
used [-Werror=unused-function]
>  static void guac_common_ssh_openssl_locking_callback(int mode, int n,
>              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> cc1: all warnings being treated as errors
> Makefile:479: recipe for target 'libguac_common_ssh_la-guac_ssh.lo' failed
> make[2]: *** [libguac_common_ssh_la-guac_ssh.lo] Error 1
> make[2]: Leaving directory '/home/mark/guacamole-server-0.9.11-incubating/src/common-ssh'
> Makefile:486: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory '/home/xxx/guacamole-server-0.9.11-incubating'
> Makefile:418: recipe for target 'all' failed
> make: *** [all] Error 2
> {code}
> Make files is not my strong suit, but it seems like there's a problem with the configure
script?
> {quote}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message