guacamole-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Jumper (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GUACAMOLE-228) RDP connection sound problems
Date Thu, 02 Mar 2017 18:28:45 GMT

     [ https://issues.apache.org/jira/browse/GUACAMOLE-228?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Jumper updated GUACAMOLE-228:
-------------------------------------
    Labels:   (was: windows)

> RDP connection sound problems
> -----------------------------
>
>                 Key: GUACAMOLE-228
>                 URL: https://issues.apache.org/jira/browse/GUACAMOLE-228
>             Project: Guacamole
>          Issue Type: Bug
>    Affects Versions: 0.9.11-incubating
>         Environment: We've tried two servers:
> 1. The latest from https://hub.docker.com/r/glyptodon/guacd/ 
> 2. Checked out and built the last commit from https://github.com/apache/incubator-guacamole-server
> Both are showing the same problems.
>            Reporter: Kjell Otto
>
> We're experiencing sound bugs when connecting via RDP to Windows 2012 R2 and Windows
2016 Servers. We've followed all the steps necessary in order to enable the sound and we're
able to connect via Windows RDP without any issue. Connect via RDP to a target PC and have
the following settings in place:
> Followed all the necessary steps gathered here: 
> https://serverfault.com/questions/549812/cant-redirect-microphone-by-rdp-no-audio-devices-are-installed#
( https://glyptodon.org/jira/browse/GUAC-1511 )
> From here: https://guacamole.incubator.apache.org/doc/gug/configuring-guacamole.html

>  - enable-audio-input
> Also, we've started the "Windows Audio" and "Windows Audio Endpoint Builder" Service.
> The problem is that weget both devices, input and output most of the time, but they never
work at the same time. The different behaviours we're experiencing are the following. These
are the quirks we've experienced and we would like to help debug them:
> 1. On Windows Server 2016: Sound is only working once. It stops working when one and
exactly one sound was played and finished. When you play the test sound for audio playback
devices, it only plays the first sound on one side of the headphones and then stops working
completely. It will start to work for one time again when you reconnect the session. If you
open the Sound sesstings, we don't see any amplitude for the "Remote Audio" microphone under
the "Recording" tab.
> 2. On Windows Server 2012 R2: We can play sounds just normally. Audio ouput is consistent
and working. Audio input is not working, same as for Windows 2016, under Sound settings in
the "Recording" tab, there is the "Remote Audio" microphone without any amplitude whatsoever.

> We've tried recording on both setups with audacity too, and with direct RDP connections
everything works as expected.
> We would love to get feedback on this and are very willing to help in any way. Please
let us know how we can help.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message