groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MG <mg...@arscreat.com>
Subject Re: IntelliJ: Full Groovy 2.5.0 Support
Date Fri, 01 Jun 2018 23:30:20 GMT
I just checked, and none of the child issues to the Groovy 3.0 umbrella 
issue (https://youtrack.jetbrains.com/issue/IDEA-188050) seems to have 
any votes. I find that not surprising: As a developer that uses Groovy 
in place of Java to develop a larger framework using IntelliJ IDE, I can 
only use a Groovy feature once it has gotten proper IntelliJ support. I 
can toy around with it before that, of course, but to e.g. to finally be 
able to get rid of using the new-keyword in my project, IntelliJ support 
is tantamount. Other new features will be useful in different ways, 
other again I will have to check out further, to find where I can use 
them best. That makes a meaningful pioritization hard - in the end I 
myself would just upvote every child issue...

Others may see this differently of course, but I need support for all 
features, as fast as possible ;-)

To prioritize, I would just do the ones that are quicker to do first.
(Or once you have create the technicl child issues in the way you need 
them structured, you can ask people to vote between 2 or 3 issues here / 
the Groovy Slack... (unless Paul/Jochen/Guillaume/... object, of course).)

It would be interesting to learn a little bit about the effort that goes 
into certain features, btw,
Cheers,
mg


On 01.06.2018 23:51, mg wrote:
> Hi Daniil,
>
> I am a bit confused here: For Groovy 3.0 someone created a similar 
> issue, people voted on it to show that Groovy 3.0 feature support was 
> important to them, you created a handful of child issues, and 
> everything seemed well & fine :-)
> How is this different then ?
>
> Cheers,
> mg
>
>
> -------- Ursprüngliche Nachricht --------
> Von: Daniil Ovchinnikov <daniil.ovchinnikov@jetbrains.com>
> Datum: 01.06.18 22:42 (GMT+01:00)
> An: users@groovy.apache.org
> Betreff: Re: IntelliJ: Full Groovy 2.5.0 Support
>
> Hi mg,
>
> First of all thank you for caring.
>
> I just want to let you know that such abstract tickets have almost 
> zero meaning other than serving as a parent for other smaller tasks.
> It would be much more helpful to prioritize if you create a ticket for 
> some particular feature and let others vote for it.
>
> —
>
> Daniil Ovchinnikov
> JetBrains
>
>
>> On 1 Jun 2018, at 21:09, MG <mgbiz@arscreat.com 
>> <mailto:mgbiz@arscreat.com>> wrote:
>>
>> Hi,
>>
>> I have created a Jetbrains issue you can vote on for IntelliJ to 
>> fully support Groovy 2.5 as soon as possible :-)
>>
>> https://youtrack.jetbrains.com/issue/IDEA-193168
>>
>> Cheers,
>> mg
>>
>>
>>
>>
>>
>


Mime
View raw message