groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Suderman <suder...@anc.org>
Subject Re: Availability of 2.5.0 groovy-all in Maven Central
Date Mon, 04 Jun 2018 02:05:38 GMT
Daniel beat me to it.  I tried using the Groovy Eclipse compiler (2.5.0-01) and I need to explicitly
set the type to 'pom' or I get a not found message for groovy-all:jar:2.5.0

- Keith


> On Jun 3, 2018, at 9:47 PM, Daniel.Sun <sunlan@apache.org> wrote:
> 
> Please add `<type>pom</type>` and try again, here is the complete pom file:
> 
> ```
> <?xml version="1.0" encoding="UTF-8"?>
> <project xmlns="http://maven.apache.org/POM/4.0.0"
>         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
>    <modelVersion>4.0.0</modelVersion>
> 
>    <groupId>me.sunlan</groupId>
>    <artifactId>try-groovy-via-mvn</artifactId>
>    <version>1.0-SNAPSHOT</version>
> 
>    <dependencies>
>        <dependency>
>            <groupId>org.codehaus.groovy</groupId>
>            <artifactId>groovy-all</artifactId>
>            <version>2.5.0</version>
>            <type>pom</type>
>        </dependency>
>    </dependencies>
> </project>
> ```
> 
> and here is result of `mvn dependency:tree`:
> ```
> [INFO] me.sunlan:try-groovy-via-mvn:jar:1.0-SNAPSHOT
> [INFO] \- org.codehaus.groovy:groovy-all:pom:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-ant:jar:2.5.0:compile
> [INFO]    |  +- org.apache.ant:ant:jar:1.9.9:compile
> [INFO]    |  +- org.apache.ant:ant-junit:jar:1.9.9:runtime
> [INFO]    |  +- org.apache.ant:ant-launcher:jar:1.9.9:compile
> [INFO]    |  \- org.apache.ant:ant-antlr:jar:1.9.9:runtime
> [INFO]    +- org.codehaus.groovy:groovy-bsf:jar:2.5.0:compile
> [INFO]    |  +- bsf:bsf:jar:2.4.0:compile
> [INFO]    |  \- commons-logging:commons-logging:jar:1.2:compile
> [INFO]    +- org.codehaus.groovy:groovy-cli-picocli:jar:2.5.0:compile
> [INFO]    |  \- info.picocli:picocli:jar:3.0.2:compile
> [INFO]    +- org.codehaus.groovy:groovy-console:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-datetime:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-docgenerator:jar:2.5.0:compile
> [INFO]    |  \- com.thoughtworks.qdox:qdox:jar:1.12.1:compile
> [INFO]    +- org.codehaus.groovy:groovy-groovydoc:jar:2.5.0:compile
> [INFO]    |  \- org.codehaus.groovy:groovy-dateutil:jar:2.5.0:runtime
> [INFO]    +- org.codehaus.groovy:groovy-groovysh:jar:2.5.0:compile
> [INFO]    |  \- jline:jline:jar:2.14.6:compile
> [INFO]    +- org.codehaus.groovy:groovy-jmx:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-json:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-jsr223:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-macro:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-nio:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-servlet:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-sql:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-swing:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-templates:jar:2.5.0:compile
> [INFO]    +- org.codehaus.groovy:groovy-test:jar:2.5.0:compile
> [INFO]    |  \- junit:junit:jar:4.12:compile
> [INFO]    |     \- org.hamcrest:hamcrest-core:jar:1.3:compile
> [INFO]    +- org.codehaus.groovy:groovy-test-junit5:jar:2.5.0:compile
> [INFO]    |  +- org.junit.platform:junit-platform-launcher:jar:1.2.0:compile
> [INFO]    |  |  +- org.apiguardian:apiguardian-api:jar:1.0.0:compile
> [INFO]    |  |  \-
> org.junit.platform:junit-platform-engine:jar:1.2.0:compile
> [INFO]    |  |     +-
> org.junit.platform:junit-platform-commons:jar:1.2.0:compile
> [INFO]    |  |     \- org.opentest4j:opentest4j:jar:1.1.0:compile
> [INFO]    |  \- org.junit.jupiter:junit-jupiter-engine:jar:5.2.0:runtime
> [INFO]    |     \- org.junit.jupiter:junit-jupiter-api:jar:5.2.0:runtime
> [INFO]    +- org.codehaus.groovy:groovy-testng:jar:2.5.0:compile
> [INFO]    |  \- org.testng:testng:jar:6.9.10:runtime
> [INFO]    |     \- com.beust:jcommander:jar:1.48:runtime
> [INFO]    \- org.codehaus.groovy:groovy-xml:jar:2.5.0:compile
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 02:47 min
> [INFO] Finished at: 2018-06-04T09:42:43+08:00
> [INFO] Final Memory: 17M/216M
> [INFO]
> ------------------------------------------------------------------------
> ```
> 
> No matter it works or not, please let me know.
> 
> Cheers,
> Daniel.Sun
> 
> 
> 
> -----
> Daniel Sun
> 
> Apache Groovy committer
> 
> Blog: http://blog.sunlan.me 
> 
> Twitter: @daniel_sun 
> 
> --
> Sent from: http://groovy.329449.n5.nabble.com/Groovy-Users-f329450.html



----------------------
Keith Suderman
Research Associate
Department of Computer Science
Vassar College, Poughkeepsie NY
suderman@cs.vassar.edu





Mime
View raw message