groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Stagner <restag...@gmail.com>
Subject Re: Availability of 2.5.0 groovy-all in Maven Central
Date Sun, 03 Jun 2018 16:57:52 GMT
Daniel,

How should this be addressed in the POM file, for those of us using Maven
to grab groovy-all?

I tried the simple coordinates like

<dependency>
    <groupId>org.codehaus.groovy</groupId>
    <artifactId>groovy-all</artifactId>
    <version>2.5.0</version>
</dependency>

but that did not work for me.

On Sun, Jun 3, 2018 at 8:13 AM Daniel.Sun <sunlan@apache.org> wrote:

> Hi Mike,
>
> FYI, http://groovy-lang.org/download.html
>
> ```
> The core plus all the modules. Also includes jarjar'ed versions of Antlr,
> ASM, Commons-CLI. In order to cater to the module system of Java 9+, only
> the individual jar files of the core and all modules will be provided since
> Groovy 2.5.0, i.e. the fat jar file groovy-all-x.y.z.jar will not be
> available. Optional dependencies are marked as optional. You may need to
> include some of the optional dependencies to use some features of Groovy,
> e.g. AntBuilder, GroovyMBeans...
> ```
>
> In short, fat jar file(i.e. groovy-all.jar) has not been provided since
> Groovy 2.5.0, but you still can use `compile
> 'org.codehaus.groovy:groovy-all:x.y.z'` to get all the individual jar
> files.
>
> Cheers,
> Daniel.Sun
>
>
>
>
> --
> Sent from: http://groovy.329449.n5.nabble.com/Groovy-Users-f329450.html
>

Mime
View raw message