groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Blake McBride <blake1...@gmail.com>
Subject Re: Upgrade Groovy jar - can't start tomcat
Date Wed, 21 Mar 2018 11:32:41 GMT
I fixed the problem - upgraded tomcat.

Thanks!

Blake


On Wed, Mar 21, 2018 at 6:01 AM, Blake McBride <blake1024@gmail.com> wrote:

> Greetings,
>
> I have been a happy user of groovy-2.3.7 for several years now on my
> tomcat webapp under Java 8.  I just updated groovy-2.3.7.jar to
> groovy-2.4.14.jar and now I am getting the following error:
>
> [...]
> Mar 21, 2018 5:47:07 AM org.apache.catalina.startup.ContextConfig
> processAnnotationsJar
> SEVERE: Unable to process Jar entry [module-info.class] from Jar
> [jar:file:/.../build/web/WEB-INF/lib/groovy-2.4.14.jar!/] for annotations
> org.apache.tomcat.util.bcel.classfile.ClassFormatException: Invalid byte
> tag in constant pool: 19
> [...]
>
>
> jar tvf groovy-2.4.14.jar    gives the expected list with no errors.  (I
> think the jar file is fine.)
>
> Sure appreciate any help!
>
> Thanks!
>
> Blake
>
>

Mime
View raw message