groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jochen Theodorou <blackd...@gmx.org>
Subject Re: compile vs compileOnly in Gradle projects for Groovy LIbraries
Date Fri, 21 Apr 2017 20:15:45 GMT
On 16.04.2017 23:38, Schalk Cronjé wrote:
[...]
>     dependencies {
>          compileOnly 'org.codehaus.groovy:groovy-all:2.4.7'
>     }
>
> This obviously means that the consumer of one of my Groovy libraries has
> to explicitly state which version of Groovy they require, but IMO it is
> better that way as it gives them more control.
>
> Thoughts?

so you would let a user execute this with say groovy 2.0?

bye Jochen


Mime
View raw message