groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keegan Witt <keeganw...@gmail.com>
Subject Re: Static type checking
Date Sat, 03 Sep 2016 14:53:15 GMT
Mihail,
Instead of adding the whole candidate directory as a global library, just
add the Groovy 2.5.0 jar as a java lib.  That worked for me.

-Keegan


On Sat, Sep 3, 2016 at 9:38 AM, Mihai Cazacu <cazacugmihai@gmail.com> wrote:

> The issue is fixed now. Thank you!
>
> I just don't know how to use this new groovy version in IntellijIdea.
> Here it is what I did so far:
>
> cd ~/.sdkman/candidates/groovy
>> git clone https://github.com/apache/groovy.git groovy-2.5.0-SNAPSHOT
>> cd groovy-2.5.0-SNAPSHOT
>> ./gradlew clean dist
>> sdk u groovy 2.5.0-SNAPSHOT
>> groovy -v
>> Groovy Version: 2.5.0-SNAPSHOT JVM: 1.8.0_91 Vendor: Oracle Corporation
>> OS: Linux
>
>
> In IntellijIdea:
>
> Project Structure -> Global Libraries -> + (New Global Library) -> try to
>> select ~/.sdkman/candidates/groovy/groovy-2.5.0-SNAPSHOT but it is not
>> accepted.
>
>
> Instead, if I choose ~/.sdkman/candidates/groovy/groovy-2.4.7, everything
> works as expected.
>
> Is there a way to make this groovy version to be accepted by IntellijIdea?
>
> Thanks!
>

Mime
View raw message