groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aristedes Maniatis <...@ish.com.au>
Subject JVM crash after groovy 2.4.6 upgrade
Date Mon, 30 May 2016 11:27:13 GMT
This is a little stab in the dark, but we are seeing JVM crashes (at least 10 so far, so it
isn't a fluke) after a recent groovy 2.4.5 -> 2.4.6 upgrade.

The crash happens here [libzip.so+0x517a] ZIP_GetEntry+0x11a which appears to be triggered
by groovy invoking the class loader to compile something.

Full details here:
    https://gist.github.com/ari/fc827478f7d48a0e5282c83a7b4ad3a4


The closest openJDK bug reports I could find are caused by something trying to change the
contents of a zip while it is open. Because I haven't yet figured how to make the JVM crash
on demand, I haven't been able to pinpoint this. And as you can see, my code involves JasperReports
invoking Groovy and there is quite a lot going on.

But I thought I'd give it a shot: has anyone seen something similar? Is this likely to be
related to the upgrade of groovy?


Cheers
Ari


-- 
-------------------------->
Aristedes Maniatis
CEO, ish
https://www.ish.com.au
GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A


Mime
View raw message