​For what I can see in the change logs for versions 2.4.4 and 2.4.5, ​groovy hasn't changed a lot, so eclipse's 2.4.3 support should be good enough IMO.

Links:
- http://www.groovy-lang.org/changelogs/changelog-2.4.4.html
- http://www.groovy-lang.org/changelogs/changelog-2.4.5.html