groovy-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russel Winder <rus...@winder.org.uk>
Subject Re: Native Launcher [was Scriptom]
Date Thu, 23 Jul 2015 11:50:43 GMT
On Wed, 2015-07-22 at 09:53 -0400, Keegan Witt wrote:
> Russel, not sure I'm following the Windows question.  The latest 
> version of
> the Windows installer was with Groovy 2.4.3, and the native binaries 
> (at
> least for groovy, groovyc, groovyConsole, and groovysh) all seemed to 
> work
> with that version of Groovy.  Although I didn't check if any new 
> arguments
> were added that weren't yet accounted for in the C program.

I am not sure how the Windows installer builds and tests, does it build
the native installer for Groovy?

The native launcher repository last ran tests using Groovy 1.7.4: the
Groovy version is effectively a parameter. If Joachin tests with the
version of Groovy being packaged and it works, that is great news.

I need to switch from using Bamboo as the test framework to using
something else, Travis, CodeShip,…? (and put a test status marker in
the README.)


> I did notice they had a Grails launcher in the source, which Joachim 
> hasn't
> been shipping in the installer.  I think it'd probably make sense to 
> delete
> that.  I also have mixed feelings on keeping the Gant launcher.  Part 
> of me
> feels like it should be part of the Gant project.
> 

Gant is an ex thing. It's only user is GINT. Though IntelliJ IDEA still
ships support for it.

-- 
Russel.
=============================================================================
Dr Russel Winder      t: +44 20 7585 2200   voip: sip:russel.winder@ekiga.net
41 Buckmaster Road    m: +44 7770 465 077   xmpp: russel@winder.org.uk
London SW11 1EN, UK   w: www.russel.org.uk  skype: russel_winder

Mime
View raw message