groovy-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul King (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (GROOVY-9061) Tests containing @Grab statements within nested scripts fail in JDK12
Date Sun, 31 Mar 2019 13:45:00 GMT

     [ https://issues.apache.org/jira/browse/GROOVY-9061?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Paul King resolved GROOVY-9061.
-------------------------------
       Resolution: Fixed
    Fix Version/s: 2.5.7
                   3.0.0-beta-1

> Tests containing @Grab statements within nested scripts fail in JDK12
> ---------------------------------------------------------------------
>
>                 Key: GROOVY-9061
>                 URL: https://issues.apache.org/jira/browse/GROOVY-9061
>             Project: Groovy
>          Issue Type: Bug
>            Reporter: Paul King
>            Assignee: Paul King
>            Priority: Major
>             Fix For: 3.0.0-beta-1, 2.5.7
>
>
> Seems to be due to the class java.security.AccessController now appearing in the execution
stack whereas it doesn't up until JDK11. This breaks the current logic for ReflectionUtils#getCallingClass
that Grab uses to find the groovy class loader.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message