groovy-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Sun (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (GROOVY-8606) Provide friendly error message for invalid lambda body
Date Fri, 25 May 2018 10:44:00 GMT

     [ https://issues.apache.org/jira/browse/GROOVY-8606?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Sun resolved GROOVY-8606.
--------------------------------
       Resolution: Fixed
    Fix Version/s: 3.0.0-alpha-3
                   2.6.0-alpha-4

Fixed by https://github.com/apache/groovy/commit/1bd642488104ca8204bd45c1c1cf4d304d7d564f

> Provide friendly error message for invalid lambda body
> ------------------------------------------------------
>
>                 Key: GROOVY-8606
>                 URL: https://issues.apache.org/jira/browse/GROOVY-8606
>             Project: Groovy
>          Issue Type: Improvement
>          Components: parser-antlr4
>            Reporter: Daniel Sun
>            Assignee: Daniel Sun
>            Priority: Major
>             Fix For: 2.6.0-alpha-4, 3.0.0-alpha-3
>
>
> We should provide friendly error message like "Statements should be wrapped in a block,
e.g. () -> { some statements here }", e.g.
> Script1.groovy: 1: Statements should be wrapped in a block, e.g. () -> { some statements
here } @ line 1, column 15.
>    def a = () -> assert 1 == 1
>                  ^



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message