groovy-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Dick (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (GROOVY-8420) @TypeChecked in 2.4.13 produces incorrect compiler error
Date Wed, 20 Dec 2017 09:26:00 GMT

     [ https://issues.apache.org/jira/browse/GROOVY-8420?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Steven Dick updated GROOVY-8420:
--------------------------------
    Summary: @TypeChecked in 2.4.13 produces incorrect compiler error  (was: 2.4.13)

> @TypeChecked in 2.4.13 produces incorrect compiler error
> --------------------------------------------------------
>
>                 Key: GROOVY-8420
>                 URL: https://issues.apache.org/jira/browse/GROOVY-8420
>             Project: Groovy
>          Issue Type: Bug
>          Components: Compiler
>    Affects Versions: 2.4.13
>         Environment: Windows 10, Java 8 Update 152, IntelliJ IDEA Build #IC-173.4127.2
>            Reporter: Steven Dick
>
> After upgrading to Groovy 2.4.13, the following code no longer compiles in Intellij:
> {code:java}
> @TypeChecked
> public class EnhancedDerivedNonUnitisedPrice {
> ...
>     public @Nullable BigDecimal getReturnPerc() {
>         return null;
>     }
> ...
> {code}
> The error is, "Cannot return 'null' from method returning BigDecimal".
> Either removing the {{@TypeChecked}} or adding a cast to {{BigDecimal}} resolves the
problem.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message