groovy-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse Glick (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GROOVY-8092) Compatibility issues between groovy 2.4.8 and jenkins workflow-cps-plugin 2.23
Date Wed, 22 Feb 2017 22:36:44 GMT

    [ https://issues.apache.org/jira/browse/GROOVY-8092?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15879385#comment-15879385
] 

Jesse Glick commented on GROOVY-8092:
-------------------------------------

I doubt there is anything to be done in Groovy itself. As of 2.4.7 there was a horrible memory
leak that the {{workflow-cps}} plugin managed to work around by using reflection to find and
null out a number of fields in internal data structures after a {{GroovyClassLoader}} became
defunct. If 2.4.8 fixes this particular leak then the workaround can be disabled. (Other leaks
probably remain.)

> Compatibility issues between groovy 2.4.8 and jenkins workflow-cps-plugin  2.23
> -------------------------------------------------------------------------------
>
>                 Key: GROOVY-8092
>                 URL: https://issues.apache.org/jira/browse/GROOVY-8092
>             Project: Groovy
>          Issue Type: Bug
>          Components: groovy-runtime
>    Affects Versions: 2.4.8
>         Environment: Jenkins 2.19-stable with a single commit that bumps groovy 2.4.8
> workflow-cps-plugin 2.23
>            Reporter: Ion Alberdi
>
> Created the issue on jenkins first
> https://issues.jenkins-ci.org/browse/JENKINS-42189
> Creating it here, in case the fix may be developed in groovy itself.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message