groovy-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GROOVY-7806) @interface has too-stringent requirement for newline
Date Sun, 03 Apr 2016 01:19:25 GMT

    [ https://issues.apache.org/jira/browse/GROOVY-7806?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15223093#comment-15223093
] 

ASF GitHub Bot commented on GROOVY-7806:
----------------------------------------

Github user asfgit closed the pull request at:

    https://github.com/apache/groovy/pull/301


> @interface has too-stringent requirement for newline
> ----------------------------------------------------
>
>                 Key: GROOVY-7806
>                 URL: https://issues.apache.org/jira/browse/GROOVY-7806
>             Project: Groovy
>          Issue Type: Bug
>          Components: syntax
>    Affects Versions: 2.4.6
>            Reporter: Hack Ster
>            Priority: Minor
>
> {code}
> // this causes an error
> @interface ANNOTATION_A 
> {
> }
> {code}
> {code}
> // this does not cause an error
> @interface ANNOTATION_A  {
> }
> {code}
> the first example should work , it does (for example) work for a class :
> {code}
> // this does not cause an error
> class CLASS_A 
> {
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message