groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Bayer <andrew.ba...@gmail.com>
Subject Re: Rename method `visit` of `ASTNode` to `accept`
Date Sat, 23 Mar 2019 20:14:29 GMT
We use it extensively in Jenkins Pipeline and script security.

A.

On Sat, Mar 23, 2019, 16:10 Paul King <paulk@asert.com.au> wrote:

> I would be cautious here. Yes, moving to the more conventional name might
> have some benefits but such a breaking change (even though within the
> org.codehaus.groovy "internal" part of the codebase) might impact many
> related projects and even end users. I would ask on the users list who uses
> that method. We don't necessarily want to force IDEs and Spock etc. to
> have to have two different versions to cater for this. An alias is a
> possibly
> more friendly way to introduce such a change, but I am not sure I'd even
> deprecate the old method straight away.
>
> Cheers, Paul.
>
>
> On Sun, Mar 24, 2019 at 2:33 AM Daniel.Sun <sunlan@apache.org> wrote:
>
>> Hi all,
>>
>>         According to the naming conventions of Visitor Pattern[1], I
>> propose
>> to rename method `visit` of `ASTNode`[2] to `accept` .
>>
>>         Any thoughts?
>>
>> Cheers,
>> Daniel.Sun
>> [1] https://en.wikipedia.org/wiki/Visitor_pattern#Java_example
>> [2]
>>
>> https://github.com/apache/groovy/blob/master/src/main/java/org/codehaus/groovy/ast/ASTNode.java#L53
>>
>>
>>
>> -----
>> Apache Groovy committer
>> Blog: http://blog.sunlan.me
>> Twitter: @daniel_sun
>>
>> --
>> Sent from: http://groovy.329449.n5.nabble.com/Groovy-Dev-f372993.html
>>
>

Mime
View raw message