groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Laforge <glafo...@gmail.com>
Subject Re: Rename method `visit` of `ASTNode` to `accept`
Date Sun, 24 Mar 2019 10:48:36 GMT
To me, it's just a cosmetic change that doesn't add any value, and has
potentially bad impact on users.
So it's more harm than good. We should avoid such changes.

On Sun, Mar 24, 2019 at 11:46 AM Daniel.Sun <sunlan@apache.org> wrote:

> Hi Guillaume,
>
>      According to the concept of OO, node accepts visitor's visiting, so
> `accept` is a correct name IMO.
>
>      > What's the point of renaming that method?
>      If we all agree with the above point, we should do the right thing,
> right?  ;-)
>
> Cheers,
> Daniel.Sun
>
>
>
> -----
> Apache Groovy committer
> Blog: http://blog.sunlan.me
> Twitter: @daniel_sun
>
> --
> Sent from: http://groovy.329449.n5.nabble.com/Groovy-Dev-f372993.html
>


-- 
Guillaume Laforge
Apache Groovy committer
Developer Advocate @ Google Cloud Platform

Blog: http://glaforge.appspot.com/
Twitter: @glaforge <http://twitter.com/glaforge>

Mime
View raw message