groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Champeau <cedric.champ...@gmail.com>
Subject Re: Binary compatibility fixed + Kotlin DSL
Date Wed, 20 Mar 2019 14:18:42 GMT
My point is that you have _no_ support with the current Groovy DSL. The new
one _does_ give support. It's MUCH easier for newcomers. Just open the
script, completion pops out. So I disagree that it makes things less
maintainable, I'm convinced of the opposite.

Le mer. 20 mars 2019 à 15:16, Daniel.Sun <sunlan@apache.org> a écrit :

> Hi Cédric,
>
> At first, thanks a lot for your maintaining the build scripts, which make
> our life easy.
>
> As for the maintainability, -1 from me.
> Since Groovy DSL can handle the build well and it is the default DSL for
> gradle(even in the IntelliJ IDEA), it's better to avoid introducing a new
> DSL. I am not sure how many developers can master both DSLs, so I'm afraid
> the build will be less maintanence than now.
>
> Cheers,
> Daniel.Sun
>
>
>
>
> -----
> Apache Groovy committer
> Blog: http://blog.sunlan.me
> Twitter: @daniel_sun
>
> --
> Sent from: http://groovy.329449.n5.nabble.com/Groovy-Dev-f372993.html
>

Mime
View raw message