groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel.Sun" <>
Subject Re: Rename method `visit` of `ASTNode` to `accept`
Date Sun, 24 Mar 2019 11:03:59 GMT
Hi  Guillaume,

> To me, it's just a cosmetic change that doesn't add any value, and has
> potentially bad impact on users.
> So it's more harm than good. We should avoid such changes.

      Renaming method `visit` of `ASTNode` to `accept` and adding an alias
method `visit` should be able to keep the back compatibility. (See

      In order to not disturb groovy users, we even do not add `@Deprecated`
to the alias method `visit`.

      To sum up, no worries :-)


Apache Groovy committer 
Twitter: @daniel_sun 

Sent from:

View raw message