groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel.Sun" <>
Subject Re: Rename method `visit` of `ASTNode` to `accept`
Date Sun, 24 Mar 2019 10:46:39 GMT
Hi Guillaume,

     According to the concept of OO, node accepts visitor's visiting, so
`accept` is a correct name IMO.

     > What's the point of renaming that method?
     If we all agree with the above point, we should do the right thing,
right?  ;-)


Apache Groovy committer 
Twitter: @daniel_sun 

Sent from:

View raw message