groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel.Sun" <sun...@apache.org>
Subject Rename method `visit` of `ASTNode` to `accept`
Date Sat, 23 Mar 2019 16:32:57 GMT
Hi all,

        According to the naming conventions of Visitor Pattern[1], I propose
to rename method `visit` of `ASTNode`[2] to `accept` .

        Any thoughts?

Cheers,
Daniel.Sun
[1] https://en.wikipedia.org/wiki/Visitor_pattern#Java_example
[2]
https://github.com/apache/groovy/blob/master/src/main/java/org/codehaus/groovy/ast/ASTNode.java#L53



-----
Apache Groovy committer 
Blog: http://blog.sunlan.me 
Twitter: @daniel_sun 

--
Sent from: http://groovy.329449.n5.nabble.com/Groovy-Dev-f372993.html

Mime
View raw message