groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel.Sun" <sun...@apache.org>
Subject About downgrading gradle to 4.10.3 on master
Date Tue, 11 Dec 2018 16:04:27 GMT
Hi all,

      After upgrading gradle to 5.0, our build on teamcity has been
failing... Here is the error message:

org.gradle.api.InvalidUserDataException: File
'/var/teamcity/buildagent-jdk8/work/cba52975ead8186f/target/poms/pom-groovy.xml'
specified for property 'mavenDescriptor' does not exist. [1]

      As a result, groovy snapshots fails to publish to
https://oss.jfrog.org/oss-snapshot-local/ , and impacts some impatient users
who eagerly want to use the latest version of groovy 3.0.

      To be honest, I'm not a gradle expert and failed to fix the build
issue, so I propose to downgrade gradle to 4.10.3 for the time being if the
build issue has not been fixed for a long time.

      BTW, if gradle expert Cedric could set aside some spare time to look
into the build issue, that would be great :-)

Cheers,
Daniel.Sun

[1]
http://ci.groovy-lang.org/viewLog.html?buildId=53717&tab=buildResultsDiv&buildTypeId=Groovy_Jdk8Build_PlusSnapshotDeploy&guest=1






-----
Daniel Sun 
Apache Groovy committer 
Blog: http://blog.sunlan.me 
Twitter: @daniel_sun 

--
Sent from: http://groovy.329449.n5.nabble.com/Groovy-Dev-f372993.html

Mime
View raw message