I'd leave the 2.5 branch.
+1 for removing everything before JDK7 on master (it's hopefully not too common anymore but it has often been convenient in the past to set the bytecode version to a version less than what you are compiling on)
+0 for removing JDK7 as well on master if others want that

On Mon, Sep 3, 2018 at 11:10 PM Daniel.Sun <sunlan@apache.org> wrote:
+1 for removing the old bytecode versions

Cheers,
Daniel.Sun




-----
Daniel Sun
Apache Groovy committer
Blog: http://blog.sunlan.me
Twitter: @daniel_sun

--
Sent from: http://groovy.329449.n5.nabble.com/Groovy-Dev-f372993.html