One of the changes in 2.5.3 is a picocli upgrade. 
A potentially breaking change is that error messages for things like missing required options have been improved in picocli-3.6.
If Nextflow uses picocli, and the tests verify the error message text, this may cause tests to fail.

On Mon, Sep 17, 2018 at 12:46 AM Paolo Di Tommaso <paolo.ditommaso@gmail.com> wrote:
The Nextflow joint build is failing with the latest snapshot version. 


Since I'm not replicate these errors I'm wondering if there's been any critical change in the latest 2.5.3-SNAPSHOT version. 


Cheers,
Paolo