groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul King <pa...@asert.com.au>
Subject Re: Java 11 Compatibility check: Apache-groovy
Date Tue, 14 Aug 2018 11:20:46 GMT
On Tue, Aug 14, 2018 at 9:10 PM Dragan, Krzysztof <kdragan@ptc.com> wrote:

> Hi,
>
> We are reaching out to you to check Java 11 compatibility of the library
> Apache-groovy
>
>
>
> Could you help us by answering the following questions:
>
>
>
> *Col 1*
>
> *Col2*
>
> *Col3*
>
> *Col4*
>
> *Col5*
>
> *Col6*
>
> *Library name*
>
> *Latest version*
>
>
> *Is the library compatible with Java 11 Compatible? (Y/N)*
>
> *Is the library supported with Java 11?*
>
> *(Y/N)*
>
> *(If ā€œNā€ in compatibility or support)*
>
> *What is the versions that would be compatible and Supported?*
>
> *Date of support availability?*
>
> *Apache Groovy*
>
> Stable: 2.5.2, Preliminary: 3.0.0-alpha-3
>
> For 2.5, Groovy classes compiled with JDK10 should run on JDK11. Groovy
> 3.0 builds and all tests pass on JDK11 but further testing is required.
>
> See previous answer.
>
> See previous answer.
>
> 2.5.2 was released yesterday. Groovy 3.0.0 final doesn't have a set target
> date yet but isn't due in the next few months.
>
>
>
> Appreciate your response by 17.08.2018
>
>
>
> Thanks,
>
> Krzysztof Dragan
>
> PTC Inc. Contractor
>
>
>

Mime
View raw message