groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russel Winder <>
Subject Re: bool
Date Mon, 23 Jul 2018 11:04:27 GMT
On Mon, 2018-07-23 at 12:40 +0200, mg wrote:
> I wanted to keep my mail concise, but also aliasing Bool = Boolean
> was more or less implied, for consistency & brevity reasons.
> I would also think that Java would introduce Int = Integer, or use
> int = Integer in that case...

When it comes to these sorts of discussion excessive brevity can leave
a lot of stuff missing!

Clearly Kotlin is going these routes to make Java types more like C++
types, but I am not convinced this is a good idea. Shrinking type
labels just to save a few keystrokes, or to conform to a 1970s view of
type names, doesn't strike me as a good rationale. If however you could
point to some psychology of programming experiments that proved code
using bool rather than boolean and/or Bool rather than Boolean
increased speed of code reading and comprehension, then you get my
wholehearted backing for the change.

Dr Russel Winder      t: +44 20 7585 2200
41 Buckmaster Road    m: +44 7770 465 077
London SW11 1EN, UK   w:

View raw message