groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keegan Witt <keeganw...@gmail.com>
Subject Re: Troubles with IDEA setup
Date Fri, 25 May 2018 09:14:39 GMT
I'm with Russel: I've seen some flakiness with Gradle Idea plugin.  On my
current client's project I actually saw Gradle Idea plugin add the wrong
version of a dependency to the project, but IntelliJ's import chose the
version that was mentioned in the Gradle file.  That did it for me -- I
permanently distrust Gradle Idea plugin now.

On Wed, May 23, 2018 at 7:33 AM, Cédric Champeau <cedric.champeau@gmail.com>
wrote:

> Thanks for checking, Marcin. For reference, stub generation takes long but
> passes. It's really the semantic analysis which gets stuck somehow.
>
> Le mer. 23 mai 2018 à 13:32, Marcin Erdmann <marcin.erdmann@proxerd.pl> a
> écrit :
>
>> Cedric,
>>
>> I've just pulled master then I got rid of all idea config files and build
>> direcotries to start with a clean state:
>>
>> rm groovy.i*
>> find . -name "*.iml" -type f | xargs rm -f
>> ./gradlew clean
>>
>> Then I run the same command as you:
>> ./gradlew jar idea --rerun-tasks
>>
>> Finally I opened the project in IntelliJ and tried rebuilding it (Build >
>> Rebuild project). The fan is spinning like crazy, CPU usage is high and it
>> seems to be stuck on "Groovy stub generator: initialization [tests of
>> groovy-xml and 8 more]". After then killing the IDE and trying to
>> run DownUpStepTest I'm seeing the same symptoms as you are - stuck in
>> "Groovyc: semantic analysis [tests of groovy-xml and 8 more]" with CPU is
>> not busy.
>>
>> For reference, I'm using IntelliJ 2018.1 181.4203.550.
>>
>> On Tue, May 22, 2018 at 8:02 PM, Cédric Champeau <
>> cedric.champeau@gmail.com> wrote:
>>
>>> Hi team,
>>>
>>> I've been trying to figure out what is happening for hours now, but I
>>> cannot find any reason. I'm working on master, after removing all IDEA
>>> state (.iml, .ipr, .iws), regenerating the IDEA files using:
>>>
>>> ./gradlew jar idea --rerun-tasks
>>>
>>> And then I open the project in IDEA and try to run a unit test. But then
>>> the IDE is stuck in "Groovyc: semantic analysis [tests of groovy-xml and 8
>>> more]". CPU is not busy, nothing happens.
>>>
>>> I thought it could be a CPU issue, so I increased the memory for the
>>> IDEA compiler process, without success.
>>>
>>> Any idea what could be going on? Am I the only one seeing this?
>>>
>>>
>>

Mime
View raw message