groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcin Erdmann <marcin.erdm...@proxerd.pl>
Subject Re: Troubles with IDEA setup
Date Wed, 23 May 2018 11:32:32 GMT
Cedric,

I've just pulled master then I got rid of all idea config files and build
direcotries to start with a clean state:

rm groovy.i*
find . -name "*.iml" -type f | xargs rm -f
./gradlew clean

Then I run the same command as you:
./gradlew jar idea --rerun-tasks

Finally I opened the project in IntelliJ and tried rebuilding it (Build >
Rebuild project). The fan is spinning like crazy, CPU usage is high and it
seems to be stuck on "Groovy stub generator: initialization [tests of
groovy-xml and 8 more]". After then killing the IDE and trying to
run DownUpStepTest I'm seeing the same symptoms as you are - stuck in
"Groovyc: semantic analysis [tests of groovy-xml and 8 more]" with CPU is
not busy.

For reference, I'm using IntelliJ 2018.1 181.4203.550.

On Tue, May 22, 2018 at 8:02 PM, C├ędric Champeau <cedric.champeau@gmail.com>
wrote:

> Hi team,
>
> I've been trying to figure out what is happening for hours now, but I
> cannot find any reason. I'm working on master, after removing all IDEA
> state (.iml, .ipr, .iws), regenerating the IDEA files using:
>
> ./gradlew jar idea --rerun-tasks
>
> And then I open the project in IDEA and try to run a unit test. But then
> the IDE is stuck in "Groovyc: semantic analysis [tests of groovy-xml and 8
> more]". CPU is not busy, nothing happens.
>
> I thought it could be a CPU issue, so I increased the memory for the IDEA
> compiler process, without success.
>
> Any idea what could be going on? Am I the only one seeing this?
>
>

Mime
View raw message