groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remi Forax <fo...@univ-mlv.fr>
Subject Re: Building Gant
Date Mon, 16 Apr 2018 19:38:33 GMT
----- Mail original -----
> De: "Jochen Theodorou" <blackdrag@gmx.org>
> À: "dev" <dev@groovy.apache.org>, "Russel Winder" <russel@winder.org.uk>
> Envoyé: Lundi 16 Avril 2018 21:22:36
> Objet: Re: Building Gant

> On 16.04.2018 19:16, Russel Winder wrote:
>> I know no-one (including me) really gives a #### about Gant these days
>> – except perhaps Bob Swift for GINT – but it is useful for testing
>> Gradle and Groovy.
>> 
>> Currently I build against:
>> 
>> 3.0.0 using my build from master/HEAD
>> 2.4.x
>> 2.5.x
>> 2.6.x
>> 
>> where I use the latest version of 2.4, 2.5, and 2.6.
>> 
>> 3.0.0-SNAPSHOT, 2.4.15, and 2.5.0-rc-1 all build and tests execute and
>> fail in not unreasonable ways. 2.6.0-alpha-3 fails due to something the
>> creates the following stack trace. I am running OpenJDK10 obviously.
>> Should I just forget Groovy 2.6.0?
>> 
>> 
>> General error during conversion: java.lang.IllegalArgumentException
>> 
>> java.lang.IllegalArgumentException
>>          at groovyjarjarasm.asm.ClassReader.<init>(ClassReader.java:160)
>>          at groovyjarjarasm.asm.ClassReader.<init>(ClassReader.java:143)
>>          at groovyjarjarasm.asm.ClassReader.<init>(ClassReader.java:418)
> 
> judging by the few examples I found online this mandates ASM 6.1.1
> (https://mvnrepository.com/artifact/org.ow2.asm/asm/6.1.1) 6.1 comes
> with Java10 support. No idea what they added in 10, that is not binary
> compatible. I was not following that so much

the support of version 54.0 and only one sentence in section 4.7.25, see https://bugs.openjdk.java.net/browse/JDK-8191867

> 
> bye Jochen

Rémi

Mime
View raw message