groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remi Forax <fo...@univ-mlv.fr>
Subject Re: Why no asm6 on Groovy2.4.x?
Date Tue, 26 Dec 2017 08:50:12 GMT
yes, 
when some dependencies are using asm-all and some are not, with the classpath, it was working
after sacrificing a goat, it does not work with modules so we have retired this artifact.


Happy Christmas, 
Rémi 

> De: "Cédric Champeau" <cedric.champeau@gmail.com>
> À: "dev" <dev@groovy.apache.org>
> Cc: "dev" <dev@groovy.incubator.apache.org>
> Envoyé: Mardi 26 Décembre 2017 08:36:28
> Objet: Re: Why no asm6 on Groovy2.4.x?

> There's no such thing as asm-all. Just like us, they had to get rid of their
> "all" artifact in 6.0. So we have to use the normal version.

> Le 26 déc. 2017 00:54, "Daniel.Sun" < [ mailto:sunlan@apache.org |
> sunlan@apache.org ] > a écrit :

>> Hi Jochen,

>> It seems that Groovy does not rely on asm-all:
>> [
>> https://github.com/apache/groovy/blob/e9b6bddda05165195db24d42ed3715e4752e0397/build.gradle#L178-L182
>> |
>> https://github.com/apache/groovy/blob/e9b6bddda05165195db24d42ed3715e4752e0397/build.gradle#L178-L182
>> ]

>> In addition, the asm's jar files can be downloaded properly(I could
>> not find "Gradle failure report"):
>> [ https://travis-ci.org/apache/groovy/jobs/321192018#L586-L596 |
>> https://travis-ci.org/apache/groovy/jobs/321192018#L586-L596 ]

>> Could you show me the link to the error messages?

>> Cheers,
>> Daniel.Sun

>> --
>> Sent from: [ http://groovy.329449.n5.nabble.com/Groovy-Dev-f372993.html |
>> http://groovy.329449.n5.nabble.com/Groovy-Dev-f372993.html ]

Mime
View raw message