groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Balachandran Sivakumar <balachand...@balachandran.org>
Subject Re: [VOTE] Release Apache Groovy 2.4.12
Date Thu, 22 Jun 2017 07:36:37 GMT
Hi Paul,

On 2017-06-22 12:16, Paul King wrote:
> Are you using:
> 
> gradle wrapper
> gradlew dist
> 
> As per README.adoc? The 'gradle wrapper' step should work bootstrapped
> with 3.5 but otherwise each Groovy distribution declares what Gradle
> version it is designed to build with as per the wrapper setup.
> 

   When I do gradle wrapper && ./gradlew dist as per README.adoc, it 
bootstraps with gradle 2.3 (because we have gradleVersion set to 2.3 ?). 
So, I explicitly tried using 3.5.

I did the following

sdk d gradle 3.5
gradle dist



When trying as per README.adoc, it builds fine. Thanks



> Cheers, Paul.
> 
> On Thu, Jun 22, 2017 at 3:59 PM, Balachandran Sivakumar
> <balachandran@balachandran.org> wrote:
> 
>> Hi,
>> 
>> The artifacts to be voted on are located as follows (r20140).
>> Source release:
>> https://dist.apache.org/repos/dist/dev/groovy/2.4.12/sources [1]
> 
>      When I try to build this from the source zip, I get the following
> build failure with Gradle 3.5
> 
> :groovydocAll FAILED
> 
> FAILURE: Build failed with an exception.
> 
> * What went wrong:
> Execution failed for task ':groovydocAll'.
> 
>> java.lang.ExceptionInInitializerError (no error message)
> 
> Build Scan: https://scans.gradle.com/s/xobecl5cdgzhg [2]
> 
> Also, on Gradle 4.0, the build fails due to build-scan plugin
> incompatibility
> 
> FAILURE: Build failed with an exception.
> 
> * Where:
> Build file '/tmp/groovy-src/groovy-2.4.12/build.gradle' line: 48
> 
> * What went wrong:
> A problem occurred evaluating root project 'groovy'.
> 
>> Failed to apply plugin [id 'com.gradle.build-scan']
>     > This version of Gradle requires version 1.7.4 of the build scan
> plugin or later.
>      Please see
> https://gradle.com/scans/help/gradle-incompatible-plugin-version [3]
> for more information.
> 
> Am I missing something or doing something wrong ? Thanks
> 
> --
> Thank you,
> Balachandran Sivakumar
> 
> 
> 
> Links:
> ------
> [1] https://dist.apache.org/repos/dist/dev/groovy/2.4.12/sources
> [2] https://scans.gradle.com/s/xobecl5cdgzhg
> [3] https://gradle.com/scans/help/gradle-incompatible-plugin-version

-- 
Thank you,
Balachandran Sivakumar

Mime
View raw message