groovy-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paolo Di Tommaso <paolo.ditomm...@gmail.com>
Subject Re: Nextflow joint build running on hold version
Date Wed, 28 Jun 2017 06:46:04 GMT
OK, now the `CI_GROOVY_VERSION` is correctly defined, however this still
does not solve the issue.

I've added a test to verify that the SNAPSHOT version is correctly used by
the build and it turns out that it is not. It just uses the groovy runtime
define in the project not the one specified by the `CI_GROOVY_VERSION`.

Condition not satisfied:

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.4.13-SNAPSHOT             |               2.4.11
                                   false
                                   10 differences (33% similarity)
                                   2.4.1(3-SNAPSHOT)
                                   2.4.1(1---------)



This is also explain why the 2.5.x build was compiling successfully, while
it doesn't on my local build.

Nextflow uses a Gradle build in which this snippet
<https://github.com/nextflow-io/nextflow/commit/93934de17e3e84c1cb690c3ec2931b38f2edb8ee>
, contributed by C├ędric Champeau, is supposed to override the project
groovy libraries with the latest snapshot.

Frankly it's not clear to me how that snippet is supposed to work, thus I
don't know if it's problem with the CI server configuration or with my
build file.


Any suggestion is welcome.


Cheers,
Paolo




On Mon, Jun 26, 2017 at 12:55 PM, Paul King <paulk@asert.com.au> wrote:

> Now set to 2.4.13-SNAPSHOT
>
> On Sun, Jun 25, 2017 at 11:03 PM, Paolo Di Tommaso <
> paolo.ditommaso@gmail.com> wrote:
>
>> Upgrading the Nextflow project to latest Groovy version (2.4.12) I got
>> several errors related to this issue:
>>
>> https://issues.apache.org/jira/browse/GROOVY-8237
>>
>>
>> I was a bit surprised because the joint build in the community Team-City
>> server is reporting all tests green:
>>
>> http://ci.groovy-lang.org/viewType.html?buildTypeId=JointBui
>> lds_Nextflow_Groovy24xJointBuild
>>
>>
>> When running in the CI server the groovy deps are overridden by this
>> snippet
>> <https://github.com/nextflow-io/nextflow/commit/93934de17e3e84c1cb690c3ec2931b38f2edb8ee>
>> in gradle build file and the groovy version is provided by the
>> `CI_GROOVY_VERSION  ` env variable.
>>
>> Looking in the log that variable looks outdated:
>>
>> [03:21:46] : [Step 1/1] Overriden Groovy dependency to use 2.4.4-SNAPSHOT
>>
>>
>> Would it be possible to update the config to have NF compiled against the
>> latest snapshot ?
>>
>>
>> Thanks you,
>> Paolo
>>
>>
>

Mime
View raw message